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What is this lecture series?

Scientific workflows: Tools and Tips A

%% Every 3rd Thursday ® 4-5 p.m. ® Webex

e One topic from the world of scientific workflows
e For topic suggestions send me an email
e |f you don't want to miss a lecture

= Check out the lecture website

m Subscribe to the mailing list

e Slides provided on Github
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https://www.bcp.fu-berlin.de/en/graduiertenzentrum/promovierende/veranstaltungen/workshops/lecture-SB/index.html
https://lists.fu-berlin.de/listinfo/toolsAndTips
https://selinazitrone.github.io/tools_and_tips/

Reproducible documents with Quarto

Quarto is an open-source scientific and technical publishing system

Basic idea: Create documents with dynamic content and text

Artwork from “Hello, Quarto” keynote by Julia Lowndes and Mine Cetinkaya-Rundel, presented at RStudio Conference 2022. lllustrated by Allison Horst
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https://allisonhorst.com/

Reproducible documents with Quarto

Document types that can be created with Quarto (examples):

e Documents: HTML, PDF, Word

e Presentations: HTML, Powerpoint
e Books: HTML, ePub, PDF

e Websites
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Before we start

Quarto is a huge topic and there are so many cool Quarto things!
Goal of today: Introduction to Quarto and an overview of different
document types and their possibilities.

e Focus on R and R Studio

e Keep in mind: This also works with other languages and other IDEs,
the principles are all the same.
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How to get Quarto

Different options, depending on your workflow:

* Infegrated in new versions of R Studio (Update R Studio via Help ->
Check for Updates)

e Download the CLI for use with other IDE (e.g. Visual Studio code)

Check out the Quarto website for download and more info.
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The classic use case

| Reproducible documents for data analysis
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An example document
An HTML example

Table of contents
1 Introduction
2 Methods
3 Results

4 References

The penguins of Antarctica

AUTHOR PUBLISHED
Selina Baldauf May 9, 2023

1 Introduction

There are three main penguin species in Antarctica (Chinstrap, Gentoo,

Adelie). You can see them in Figure 1:

%

I

GEINTOO!  ADELy

Figure 1: lllustration of the three penguin species by Allison Horst
In this paper we want to answer the following questions

1. How bill depth depends on bill length?
2. Which penguin species has the highest body mass?

2 Methods

All analysis was done using R version 4.1.3 (R Core Team 2022) and the R
markdown package (Allaire et al. 2021).

2.1 The data

The data was collected on islands in Antarctica and published by Gorman,
Williams, and Fraser (2014). You can find the original paper with the title
"Ecological sexual dimorphism and environmental variability within a

rammimnity nf Antarctic nenaning fnenne Puancrelicd” (Garman Williame
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file:///C:/Users/Selina/Repos/Teaching/tools_and_tips/docs/sessions/additional_material/02_quarto/penguins_paper.html

A standard workflow

[ 1. Data management H 2. Data analysis H 3. Report/Publication J

R ® LIEX & R

Problem: Manual updates are error prone and non-reproducible
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A Quarto workflow

Solution: Use a Quarto workflow = everything (code, text, metadata) in
one place. Let Quarto do the magic

[ 1. Data management H 2. Data analysis ) 3. Report/Publication J

N—
Quarto

Advantages of this workflow:

e Easy to redo analysis
e No more copy pasting

e Reproducible

Download a quarto demo project from Github
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https://github.com/selinaZitrone/quarto_demo

The basic Quarto workflow

1. Create a .qgmd document
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Step 1 - Create the document

Open R Studio and go to File -> New File -> Quarto Document

MNew Quarto Document

Document Title: Untitled

17_.\.[ Presentation Author: {optional)

R Interactive
® HTML

Recommended format for authoring (you can switch to PDF
or Word output anytime)

PDF
PDF output requires a LaTeX installation {e.g.
https:/fyihui.org/tinytex/)

Word
Previewing Word decuments requires an installation of M3
Word (or Libre/Open Office on Linux)
Engine: Kmitr

Editor: | Use visual markdown editor (7

7! Learn more about Quarto

Create Empty Document Create Cancel

Just click create and the file will open in R Studio.

In other environments you can just create and empty file with . gmd
en d | N 9 Selina Baldauf// Quarto
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The basic Quarto workflow

1. Create a .qgmd document

2. Write the document

e fexte.g. infroduction, methods, or discussion
e code (R, Python, Julia) that produces numbers, figures, tables, ...

* metadata that defines how the document should look like (e.g. which
output format)

3. Render the document to a defined output format (e.g. PDF) using

Quarto
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Step 3 - Render the document

e Click the Render button in R Studio
e Keyboard shortcut ctrl + shift + K
e Call the quarto: :quarto_render() function

e |n the terminal: quarto render doc.gmd
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Basic Elements of a .qmd
document

Text body, Code, YAML header
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References for all the elements

e Mardown syntax reference
e Code chunks:

= R code

m Python code
e YAML header options:

s HTML

m PDF

= DOCX
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https://quarto.org/docs/authoring/markdown-basics.html
https://quarto.org/docs/computations/r.html
https://quarto.org/docs/computations/python.html
https://quarto.org/docs/reference/formats/html.html
https://quarto.org/docs/reference/formats/pdf.html
https://quarto.org/docs/reference/formats/docx.html

The text body - Markdown

Markdown is a simple markup language to create formatted text, you can
e.g.

e Make italic fext with *text* or bold text with * *text* *

e Generate headers of different levels

# Header level 1
## Header level 2
### Header level 3

e Create bullet lists

A bullet point list
- 1item 1

- item 2
- item 3
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The text body - Markdown

You can also do more complex things like:

e Including images, links or footnotes
e Adding citations

e Latex style mathematical formulas
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The text body - Markdown

f you don't want to use markdown, there is a really nice feature in R
Studio: The visual editor.
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The visual editor in R Studio

Convenient, word-like interface for formatting text and adding features.

1_penguins_paper_pasic.qmd | 2_penguins_paper_yaml.gmd * | penguin_presentation1.gmd » ]
jRender onSave ., O | =P Render - 'C | *Run v ‘&~

Source | Visual B I <> Header2 ~ ~ ®=|  Format ¥ | Insert ¥ | Table ~
author: "Selina Baldauf" -

date: "'r Sys.Date() "
format: html

v {r} - )
#| label: setup
#| include: false
library(tidyverse
library(palmerpenguins

Introduction

There are three main penguin species in Antarctica (Chinstrap, Gentoo, Adelie). You can see

them in the following figure:
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The visual editor in R Studio

Using the visual editor, makes many things that would be painful in
Markdown really easy.

My favorite feature in the visual editor:

e Add citations (Insert -> Citation) from Zotero library, DOI search,
PubMed, ...
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The Code

Code can be included in code chunks or as inline code

Selina Baldauf// Quarto
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The Code

Inline code starts and ends with 1 backtick

\ r \

Example

The mean of the values 1, 2 and 3 is 'r mean(1:3)°
looks like this:

The mean of the values 1, 2 and 3 is 2.

Selina Baldauf// Quarto
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The Code

Code chunks starts and ends with 3 backticks

o A{r3
library(ggplot2)

ggplot(airquality, aes(Temp, Ozone)) +
geom_point() +
geom_smooth(method = "loess")

~" {python}
import numpy as np
import matplotlib.pyplot as plt

r = np.arange(0, 2, 0.01)

theta = 2 * np.pi * r

fig, ax = plt.subplots(subplot_kw = {'projection': 'polar'})
ax.plot(theta, r)

ax.set_rticks([0.5, 1, 1.5, 21)

ax.grid(True)

plt.show()

Selina Baldauf// Quarto
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The Code
Insert a code chunk (R Studio)

e |nsert a code chunk by going to Code -> Insert chunk

e Use the keyboard shortcut Ctrl + Alt + I / Cmd + Option + I

¢ Inline chunks have to be typed or use the </> symbol in visual mode

Selina Baldauf// Quarto
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The Code

Run code chunk

e Code chunks are run when document is rendered

e Code chunks can also be run like “normal” code

e Run Code chunk by clicking on the green arrow next to the chunk

**{r cars} »
summary {cars)

Selina Baldauf// Quarto
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The code

Code chunk have special comments that start with #| and that control the
behaviour of the chunk.

A

#| label: fig-airquality

#| fig-cap: Temperature and ozone level.
#| include: false

library(ggplot2)
ggplot(airquality, aes(Temp, Ozone)) +

geom_point() +
geom_smooth(method = "loess")

e label: Figure and chunk label that can be referred to in text
® fig-cap: Figure caption

e include: Include the output (i.e. the plot) in the document but don't
show the code

Selina Baldauf// Quarto
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YAMIL header
For Metadata

title: "My first document"

subtitle: "Whatever subtitle makes sense"
author: "Selina Baldauf"

date: "'r Sys.Date()""

* Inline R code can print the current date at render time
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YAML header

For document output formats

title: "My first document"
author: "Selina Baldauf"
date: "'r Sys.Date()""
format: html

You can also specity multiple output formats

title: "My first document"
author: "Selina Baldauf™
date: "'r Sys.Date()""
format:

html: default

pdf: default

docx: default

Selina Baldauf// Quarto
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YAMIL header

For document options

e Some options are shared
between formats, some are
specific o one format

e Be careful to get the

indentation right!

title: "My first document”

author: "Selina Baldauf™
date: "'r Sys.Date()'"
format:
html:
number-sections: true
toc: true
toc-location: left
pdf:
toc: true
number-sections: true
docx: default
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YAML header

Execute options

e Default options for code chunks

e Can be overwritten by local comments in code chunks

title: "My first document"
author: "Selina Baldauf"
date: "'r Sys.Date()'"
format: html
execute:

message: false

warning: false
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Summary

e Quarto combines formatted text and code to create reproducible
documents

Use cases for scientists

e Data analysis reports and documents

e Use gmd instead of .R scripts to add text to the code (e.g. for
interpretation or method description)

e Use it for teaching material

e o o

Selina Baldauf// Quarto
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Outlook

Quarto offers many more things like:

e Presentations (Powerpoint or Revealjs/HTML)
e Websites

e Easily publish your documents or websites on quartopub or Github
m See here for more information

e Control the rendering process via R scripts using

quarto: :quartozrender()

e Parameterized reports
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https://quartopub.com/
https://quarto.org/docs/publishing/

Next lecture

Version control with Git

Git is an essential skill it you use any programming language. It allows
you to keep track of changes over time, collaborate with others, and
maintain a clear and organized file structure. This can save time, improve
research efficiency, and makes it easy to publish your code.

%7 15th June @ 45 p.m. ¢ Webex

Subscribe to the mailing list

® For topic suggestions and/or feedback send me an email
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Thank you for your attention :)

Questions?




References

e Quarto website offers everything you need to get started
= Download Quarto and starting guide for different IDEs
m Guides for different output formats
= Gallery with Examples

e Quarto infroduction workshop on Youtube

e A curated collection of resources
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